Provisioning accounts currently down in EU regions
Resolved
This incident has been resolved.
Posted 9 days ago. Apr 11, 2019 - 17:00 UTC
Update
We are continuing to investigate this issue.
Posted 9 days ago. Apr 11, 2019 - 15:10 UTC
Investigating
This issue is known to us and we are currently investigating with MSFT dynamics on this issue.

Please stand by for updates.
Posted 9 days ago. Apr 11, 2019 - 15:10 UTC
This incident affected: Onboarding Service.