Live Assist 3rd Party Incident - NA Region

Resolved

Our provider's engineering teams have mitigated the reported issue. Subsequent checks have confirmed the service's health and stability. If you have any issues related to this incident, please contact our technical team at support@liveassistfor365.com.
Posted Mar 20, 2026 - 05:54 UTC

Monitoring

Our provider's technical teams are continuously monitoring the system's performance and implementing mitigation actions.
Posted Mar 20, 2026 - 05:19 UTC

Identified

Our provider's technical teams have identified a potential cause and are taking action to mitigate the reported behavior.
Posted Mar 20, 2026 - 04:33 UTC

Update

The issue is still being investigated, and our provider is making steady progress toward resolving it.
Posted Mar 20, 2026 - 03:40 UTC

Investigating

Our third-party service provider is experiencing technical issues with the messaging service. Conversations may not be routing properly, and message delivery capabilities may be impacted. Their engineers are actively engaged in identifying and addressing the behavior. An update will be provided as soon as we receive additional information from our provider.
Posted Mar 20, 2026 - 02:58 UTC
This incident affected: Messaging Service.