Agent Workspace - All Region

Resolved

Our partner teams have concluded their investigation and confirmed that the service has returned to normal operation. If you are still experiencing issues please contact our technical team by emailing support@liveassistfor365.com.
Posted Apr 18, 2026 - 11:20 UTC

Investigating

Our third-party service provider is currently experiencing technical issues affecting the Conversational Cloud platform. As a result, users may be unable to access historical conversations or view conversations assigned to them. We will provide an update as soon as we receive additional information from our provider.
Posted Apr 18, 2026 - 10:54 UTC
This incident affected: Supervisor Portal.