Issues with Conversation Cloud

Resolved

Technical teams have concluded their investigation and confirmed that the service has returned to normal operation. We will continue to monitor the situation to ensure continued stability. If you are still experiencing issues, please contact our Customer Care team.
Posted Mar 18, 2026 - 15:24 UTC

Identified

Our 3rd party service provider has successfully restored the primary service responsible for the recent disruption. Focus has now shifted to restarting all dependent services. We are monitoring the recovery closely to ensure stability and will provide further updates as systems return to full capacity.
Posted Mar 18, 2026 - 14:32 UTC

Investigating

Our 3rd party service is experiencing issues with Conversation Cloud. Agents and customers may not be able to send messages, or message delivery latency may be observed. Users may be unable to log in or may get kicked out of the platform. Copilot Rewrite may also be temporarily unavailable. Technical teams are currently working to resolve the reported behavior.
Posted Mar 18, 2026 - 13:29 UTC
This incident affected: Chat Service, Campaign Management Portal, Supervisor Portal, and Messaging Service.