Engineering teams have resolved the issue affecting the Manager Workspace. Subsequent checks have confirmed the service's health and stability.
Posted Jan 22, 2026 - 13:05 UTC
Identified
Our third-party service provider is currently taking action to remedy the issues that were experienced and is actively monitoring the platform for improvements in performance and overall system health.
We are seeing significant improvements in the Manager Workspace. The information cards are now loading correctly, and data is present. Validation efforts are still ongoing to ensure continued stability.
We will continue to monitor the situation closely and share further updates as they become available.
Posted Jan 22, 2026 - 12:20 UTC
Investigating
Our third-party service provider is currently experiencing issues with the Conversational Cloud platform.
As a result, the Manager Workspace may fail to load or display data correctly. This may be indicated by a red triangle error and the message: “Please wait for the system to refresh or try refreshing your browser.”
Our engineering teams are actively working to identify and resolve this issue. We will share updates as soon as more information becomes available.
Posted Jan 22, 2026 - 11:38 UTC
This incident affected: Campaign Management Portal.