Login issues with Conversational Cloud platform (NA region)

Resolved

Engineering teams have mitigated the reported issue. Subsequent checks have confirmed the service's health and stability.
The system is fully recovered.
Posted May 19, 2026 - 08:01 UTC

Investigating

Our 3rd party service provider is experiencing technical issues with our Conversational Cloud platform. Users may be unable to log in or may get kicked out of the platform. Our engineering teams are working to resolve the detected behavior.
Posted May 19, 2026 - 07:40 UTC
This incident affected: Campaign Management Portal and Supervisor Portal.