Live Assist 3rd Party Incident - EMEA Region

Update

Our third-party service provider is experiencing technical issues and is actively investigating and working to resolve the issue as quickly as possible. If it’s possible to capture a HAR file of the issue, it would be very helpful for our engineers. Once available, you can share it through the case or in whichever way is most convenient for you.

We will provide updates as soon as more information becomes available.
Posted Jul 18, 2025 - 06:15 UTC

Investigating

We are currently experiencing a technical issue with the Engagement Portal.
After assignment, agents may be unable to view conversations in the "My Conversations" queue.

Our engineering teams are actively investigating and working to resolve the issue as quickly as possible.
We will provide updates as soon as more information becomes available.
Posted Jul 17, 2025 - 11:53 UTC
This incident affects: Supervisor Portal.