Provisioning Unavailable in EU and NA
Resolved
We identified the issue and were able to restore service.
Posted 19 days ago. Sep 04, 2019 - 17:28 UTC
Investigating
We are currently aware of an issue which is affecting the ability to create new accounts in the EU and NA region.
Posted 19 days ago. Sep 04, 2019 - 14:14 UTC
This incident affected: Onboarding Service.