Supervisor portal is unavailable in all regions
Resolved
This incident has been resolved for all regions.
Posted Mar 18, 2024 - 17:55 UTC
Investigating
We are currently aware of an issue affecting the supervisor portal in all regions.
We are investigating and will provide updates as and when available.
Posted Mar 18, 2024 - 16:12 UTC
This incident affected: Supervisor Portal.