Live Assist 3rd Party Incident - All Regions

Resolved

A solution has been put in place to resolve this. If you are still experiencing issues, please try to: Log out of the Engagement Portal, clear your cache, restart your browser and then log back into the Engagement Portal.
Posted Aug 29, 2025 - 23:21 UTC

Investigating

Our third-party service provider is experiencing a technical issue where the Engagement Window Studio of the Engagement Portal may be inaccessible. We will provide an update as soon as we receive additional information from our provider.
Posted Aug 29, 2025 - 07:27 UTC
This incident affected: Campaign Management Portal.