Technical issues with the Conversational Cloud platform NA region

Resolved

The issue was resolved due to the successful completion of automated system recovery.
If you are still experiencing issues, please contact our Support team.


Region:
Posted Nov 10, 2025 - 12:39 UTC

Identified

The fix has been implemented, pending full system recovery
Posted Nov 10, 2025 - 12:18 UTC

Investigating

Our third-party service provider is currently experiencing technical issues with the Conversational Cloud platform. Agents may be unable to send messages, and delays in message delivery may occur. Users who are already logged in may also experience latency, difficulty navigating between tabs, or issues handling conversations.
Our technical teams are actively working to resolve the reported behavior.
Posted Nov 10, 2025 - 11:52 UTC
This incident affected: Campaign Management Portal, Supervisor Portal, and Messaging Service.