Provisioning accounts currently down in EU region
Resolved
There was a service outage for onboarding caused by an upstream partner.
We identified the issue and were able to restore service.
We have now resolved the issue.
Posted 3 months ago. May 23, 2019 - 13:01 UTC
Investigating
This issue is known to us and we are currently investigating with our partners on this issue.

Please stand by for updates.
Posted 3 months ago. May 21, 2019 - 17:03 UTC
This incident affected: Onboarding Service.