Service Degraded - Impacting users in NA region
Resolved
All services are back online and working.
Posted Nov 08, 2020 - 10:09 UTC
Monitoring
We have identified a traffic issue that was effecting Live Assist and have restored service.
We will continue to monitor the situation.
Posted Nov 07, 2020 - 21:42 UTC
Investigating
Service Impact: Degraded

Affected Regions: NA

Summary: We experienced an issue where the service was rejecting User login's Intermittently.
Posted Nov 07, 2020 - 19:18 UTC
This incident affected: Co-browse Service, Chat Service, Chatbot Service, Voice and Video Escalation Service, Administration Portal, Campaign Management Portal, and Billing Portal.