Our third-party service provider has mitigated the reported issue. Subsequent checks have confirmed the service's health.
Posted Mar 07, 2026 - 15:46 UTC
Update
Additional validation steps are being completed to ensure the platform's stability.
Posted Mar 07, 2026 - 15:27 UTC
Monitoring
We are seeing improvements with the service. Continuous validation efforts are ongoing by our teams to ensure optimal platform health.
Posted Mar 07, 2026 - 15:12 UTC
Update
Our third-party service provider is continuously monitoring the system's performance and health after implementing the mitigation steps.
Posted Mar 07, 2026 - 14:44 UTC
Identified
Our third-party service provider has restarted an underlying component and is monitoring for improvement.
Posted Mar 07, 2026 - 14:25 UTC
Investigating
Our third-party service provider is experiencing an issue where the Conversation Engagements may not appear or they may appear with latency on the web pages. We will provide an update as soon as we receive additional information from our provider.
Posted Mar 07, 2026 - 14:23 UTC
This incident affected: Campaign Management Portal and Supervisor Portal.