Problems with Voice/Video Escalation
Resolved
This issue has now been resolved.
Posted Aug 14, 2019 - 14:40 UTC
Investigating
We are currently investigating an issue with Voice & Video escalation.
Posted Aug 14, 2019 - 13:41 UTC
This incident affected: Voice and Video Escalation Service.