Live Assist 3rd Party Incident - North America

Resolved

The team has found and addressed the reported issue, as we are seeing improvement in service performance. Additional validation steps have been completed to ensure the platform's stability moving forward.
Posted Mar 07, 2025 - 21:24 UTC

Investigating

Our third-party service provider is experiencing technical issues with their MTLS service. Agents may not be able to send messages, and latency in message delivery may be observed. Our technical teams are working to resolve the reported behavior. We will provide update as soon as we receive additional information from our provider.
Posted Mar 07, 2025 - 20:36 UTC
This incident affected: Co-browse Service, Chat Service, Chatbot Service, Voice and Video Escalation Service, and Messaging Service.