Billing portal is not accessible
Resolved
The service has now been restored across all regions.
Posted 10 months ago. Sep 18, 2018 - 11:53 UTC
Investigating
We are investigating the reason for the issue. We suspect it is related to an upgrade that is currently in progress. We will provide an update shortly.
Posted 10 months ago. Sep 18, 2018 - 11:30 UTC
This incident affected: Billing Portal.