Live Assist Suspected Incident - NA Region

Resolved

This incident has been resolved. If you are still experiencing the issue, please raise a support request by emailing support@liveassistfor365.com.
Posted Dec 05, 2025 - 01:42 UTC

Investigating

We are experiencing an issue where the Live Assist Admin Portal is inaccessible. Our technical teams are already engaged and investigating. If you experience such issues, please contact Live Assist Technical Support at support@liveassistfor365.com.
Posted Dec 05, 2025 - 00:44 UTC
This incident affected: Administration Portal.