The incident is fully resolved, and our systems have returned to normal. We suspect a third-party network outage affected multiple cloud applications. We are working with our vendor to confirm the root cause and identify preventive measures.
Posted Feb 20, 2026 - 19:54 UTC
Monitoring
The fix has been implemented, pending full system recovery
Posted Feb 20, 2026 - 19:29 UTC
Identified
We are seeing significant improvements with Conversation Cloud platform, with login now working. Our teams are continuing validation efforts to ensure optimal platform health.
Posted Feb 20, 2026 - 18:53 UTC
Investigating
We are experiencing technical issues with our Conversational Cloud platform. Users may be unable to log in or may get kicked out of the platform. Our engineering teams are working to resolve the detected behavior.
Posted Feb 20, 2026 - 18:35 UTC
This incident affected: Chat Service, Campaign Management Portal, Supervisor Portal, and Messaging Service.