Support Page Outage
Resolved
This issue has now been resolved.
The third party has now resolved the issue following some configuration changes.
Posted Nov 25, 2021 - 13:54 UTC
Identified
We are aware of the issue and will continue investigating.
We are chasing the third party service for this request and will let you know when we have further information.

We apologise for any inconvenience caused.
Posted Nov 25, 2021 - 10:31 UTC
Investigating
We are currently experiencing an outage of our support page. (https://support.liveassistfor365.com)
Due to an issue with a third party providing automatic renewal of SSL certificate verification.
Posted Nov 25, 2021 - 01:15 UTC